Message
  • EU e-Privacy Directive

    This website uses cookies to manage authentication, navigation, and other functions. By using our website, you agree that we can place these types of cookies on your device.

    View Privacy Policy

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Module Disappears?

Module Disappears? 6 years 6 months ago #1765

  • andrea_4g
  • andrea_4g's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1121
  • Thank you received: 163
More likely than not it's something SEF-related.
Try disabling SEF and see if that fixes the problem.
Then we can start troubleshooting from there.
The administrator has disabled public write access.

Module Disappears? 6 years 6 months ago #1767

Looks like it is sef.

Turned SEF URL's off and it works perfectly now... but I need SEF on...

Any ideas?
The administrator has disabled public write access.

Module Disappears? 6 years 6 months ago #1769

  • andrea_4g
  • andrea_4g's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1121
  • Thank you received: 163
Tip: You can find answers in other threads on this site.

I would start disabling SEF selectively for Custom Properties, assuming you are using a third-party SEF component that allows that.

If you are using native SEF, you can try this solution (that often proved resolutive):
www.solidsystem.it/forum/8-cp-20-for-j16...t-is-shown.html#1399
Last Edit: 6 years 6 months ago by andrea_4g. Reason: added second suggestion
The administrator has disabled public write access.

Module Disappears? 6 years 6 months ago #1770

OK,

change 'Use Itemid:' to 'None' in component config area. It was on 'Current Page'.

All seems OK now.

Thanks for your help.


So to sum up...

To get the module to show on the same page as the tag search results I did the following...

Created hidden menu.

Added 'Custom properties' menu item to the hidden menu. (noted the menu ID)

Opened module and assigned module to that the above menu (and any other menus I wanted it to appear on)

Put menu ID from above into 'ItemID' field at bottom right of module settings. Saved.

Opened 'Custom Properties > Config and change 'Use Itemid:' to 'None'.

The administrator has disabled public write access.

Module Disappears? 6 years 6 months ago #1797

OK,

Firstly let me thank you for your support so far. It has been outstanding.

I have it running well now.

Just one more problem... if I click the tag in the tag module, then the module does not disappear. However if I click the tag in the article it show the search results but now the modules have disappeared again...

So how do i target the modules so they stay when click the tags with the articles?

Thank you.
The administrator has disabled public write access.

Module Disappears? 6 years 6 months ago #1800

Not to worry, I used advanced module manager. It all works now.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.116 seconds