Message
  • EU e-Privacy Directive

    This website uses cookies to manage authentication, navigation, and other functions. By using our website, you agree that we can place these types of cookies on your device.

    View Privacy Policy

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: No modules when the search result is shown

No modules when the search result is shown 8 years 9 months ago #1398

  • martin_s
  • martin_s's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
Hallo!

I just installed Custom Properties and it works quite nice.
There is only one problem for me, that is that on the page which shows the results if I click on a assigned tag, there are no modules displayed. I just get the results shown.
Do I jhave an error in my thinking, I saw at thze demo page that the assigned modules are shown.

Would be graet if you could have a look here:

www.rdmag.de/rd/reviews/28-autopsy-the-tomb-within.html

If you click on the "A" Tag you will see that the content of the search is displayed, but bno modules anymore.

I would be so glad if you could help me!

Best wishes and thanks in advance!
Martin
The administrator has disabled public write access.

No modules when the search result is shown 8 years 9 months ago #1399

  • andrea_4g
  • andrea_4g's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1122
  • Thank you received: 163
The following is a sure way to have the modules assigned to the result page:

- Create a new menu.
- Let's call it "hidden"
- Add a menu item of type Custom Properties view = default.
- Name it with something meaningful ,because it will show up in the URL (eg "advanced search")
- Save and take note of the Itemid of that menu item.
- Edit the cpsearch module (or the cpcloud module)
- Set the Itemid param to the previously noted Itemid
- Assign the module it to two pages : the one you want to search from, and the new "advanced search" page
The administrator has disabled public write access.

No modules when the search result is shown 8 years 9 months ago #1400

  • martin_s
  • martin_s's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
Hi Andrea,

thank you so much for your help!
I came a big stap forward, one problem is still there.
I did what you wrote, I created the new Menu and the item. In my case the type is "Custom Properties Layout" the only one I am able toi choose.
I did all the rest you wrote, too.
If I now go over the serach moodule which is at the moment located at the end of this site:

www.rdmag.de/rd/reviews/37-autopsy-the-tomb-within-6.html

It works perfectly.
But I I click on the "A" Tag, etc. I still get to the page without modules.
Are you able to see any mistake I did?

Best wishes!

Martin
The administrator has disabled public write access.

No modules when the search result is shown 8 years 9 months ago #1401

  • andrea_4g
  • andrea_4g's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1122
  • Thank you received: 163
You are almost there.

You should set the Itemid to the Custom Properties Menu too.

Also don't forget to assign both modules (cpsearch and comenu) to the "hidden advanced-search" menu item, so that they show up on the result page too.

That should work.
The administrator has disabled public write access.

No modules when the search result is shown 8 years 9 months ago #1402

  • martin_s
  • martin_s's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
Hi Andrea,

that works all great now thanks a lot, last thing is only that if I go into anarticle like:

www.rdmag.de/rd/reviews/37-autopsy-the-tomb-within-6.html

and click on the tag below the article like on "Autopsie" then I still get to the page without the modules. If that will work you will se me really happy!

Best!
Martin
The administrator has disabled public write access.

No modules when the search result is shown 8 years 9 months ago #1403

  • andrea_4g
  • andrea_4g's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1122
  • Thank you received: 163
You can try changing parameter 'Use Itemid' in main Custom Properties configuration.
The default is 'None'. Try with 'Current Page'
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.059 seconds